During our investigation with the service provider, we identified a scenario where unusually long email addresses were causing issues with email processing. The issue has now been resolved. If you continue to experience any problems, please reach out to our support team.
Posted Jul 21, 2025 - 08:57 EDT
Update
Our teams are actively working with the service provider to resolve the issue. At this time, there is no estimated time for resolution. We will provide the next update once significant progress has been made.
Posted Jul 19, 2025 - 06:05 EDT
Investigating
We are currently experiencing issues with OAuth authentication when connecting to Office 365/Exchange Online servers using SMTP, IMAP, and POP3 protocols. Our team is actively working with our service provider to investigate and resolve the issue. At this time, there is no estimated time for resolution. We will provide updates as more information becomes available.