This incident has been resolved and it was observed that clients are operating normally.
Posted Mar 09, 2025 - 21:06 EDT
Monitoring
A fix has been implemented and we are monitoring the result.
Posted Mar 09, 2025 - 12:51 EDT
Update
Our service provider continues to mitigate this intermittent issue. There is no ETA for now. The next update will be provided within 60 minutes, or as events warrant.
Posted Mar 09, 2025 - 11:45 EDT
Identified
Our service provider has identified the issue as an unexpected spike in usage affecting backend resources impacting the student application. They are actively investigating mitigation options. At this time, we don't have an ETA, but we will update the progress in next 60 mins.
Posted Mar 09, 2025 - 10:44 EDT
Investigating
Starting March 9th at 8:05 AM EST, users in the West US region may experience intermittent issues with the student application, including timeouts and increased latency. We are actively working with our service provider to resolve the issue and will provide an update within 60 minutes or as soon as new information becomes available.
Posted Mar 09, 2025 - 09:49 EDT
This incident affected: Americas (Anthology Student).