Mailbox Manager down for Student

Incident Report for Anthology

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 11:12 EDT

Monitoring

A fix has been applied, and some users may begin to see recovery. We are actively monitoring the situation.
Posted Aug 26, 2025 - 00:05 EDT

Identified

Starting at 12:29 PM EST, users began experiencing issues with the Mailbox Manager feature, which may have impacted their ability to manage mailbox settings and related functions. Our engineering team is actively investigating the root cause and working on mitigation steps to restore full functionality. We will provide further updates as soon as more information becomes available or within the next 60 minutes. We apologize for the inconvenience and appreciate your patience.
Posted Aug 25, 2025 - 21:23 EDT
This incident affected: Americas (Anthology Student).