Anthology Student is down

Incident Report for Anthology

Resolved

The issue has been identified as part of planned maintenance. There is no unexpected system fault. We apologize for any confusion and appreciate your understanding.
Posted Apr 25, 2026 - 01:35 EDT

Investigating

We have identified an issue affecting student applications through our monitoring systems. Our technical team is actively working to resolve it, and we will provide updates as soon as more information becomes available.
Posted Apr 25, 2026 - 01:06 EDT
This incident affected: Americas (Anthology Student).